Тест по информатике Алгоритм как модель деятельности для 11 класса

Тест по информатике Алгоритм как модель деятельности для 11 класса. Тест включает 2 варианта, в каждом варианте по 5 заданий.

1 вариант

1. Алгоритм является

1) информационной моделью деятельности исполнителя
2) табличной моделью
3) графической моделью
4) системой команд исполнителя

2. Алгоритм кодирования представлен в словесной фор­ме. Для кодирования букв С, Д, Е, Г используют двухразрядные последовательные двоичные числа (от 00 до 11 соответственно). Если таким способом закодировать последовательность символов ГДСЕ и записать результат шестнадцатеричным кодом, получится

1) Е2
2) DE
3) D2
4) А8

3. Дан следующий алгоритм.

a:=20;
b:=(а mod 10)*10;
a:=(b*2)+a div 100
если a>b
то c:=a+b
иначе c:=b-a
все

После его выполнения переменная c примет значение

1) 0
2) 20
3) -20
4) 45

4. Дан следующий алгоритм

нц для i=1 до n
нц для j=1 до n
p:=a[i,j];
a[i,j]:=a[j,i];
a[j,i]:=p
кц
кц

В результате его выполнения в массиве a

1) значения элементов отобразятся симметрично относительно главной диагонали
2) первая и последняя строки поменяются местами
3) все элементы примут значения, равные p
4) строки и столбцы поменяются местами

5. Запишите, как называется пошаговое исполнение алгоритма с тестовым вариантом исходных данных.

2 вариант

1. Алгоритм не может быть представлен в форме

1) дерева
2) информационной модели
3) блок-схемы
4) программы на алгоритмическом языке

2. Алгоритм кодирования представлен в словесной форме. Для передачи сообщения используют следующее кодирование символов: А-001. В-010, С-011, D-100, Е-101, F-110. Если таким способом закодировать сообщение ABCDB и перевести его в шестнадцатеричный код, получится

1) 4Е2
2) 14Е2
3) 142Е
4) Е20

3. Дан следующий алгоритм

a:=30;
b:=30;
a:=a-b/2
если а>b
то c:=a+b
иначе c:=b-a
все

После его выполнения переменная c примет значение:

1) 0
2) 15
3) 60
4) -15

4. Дан следующий алгоритм

k:=0;
нц для i=1 до 3
нц для j=1 до 3
b[j,i]:=k;
k:=k+1
кц
кц

Значения элементов массива b, записанные построчно:

1) 012, 345, 678
2) 036, 147, 258
3) 258, 147, 036
4) 013, 246, 678

5. Запишите, как называется модель работы процессора при исполнении алгоритма.

Ответы на тест по информатике Алгоритм как модель деятельности для 11 класса
1 вариант
1-1
2-3
3-1
4-1
5. Трассировка алгоритма
2 вариант
1-1
2-1
3-2
4-2
5. Трассировочная таблица

Опубликовано: 07.12.2021 Обновлено: 25.12.2021

Добавить комментарий

Ваш адрес email не будет опубликован.

6 + девять =